Back to overview
Degraded

Amazon Inventory Syncing Degradation

May 06 at 09:00am EDT
Affected services
Amazon Integration

Resolved
May 06 at 10:21am EDT

We are pleased to announce that the issue affecting the Amazon Inventory Syncing services has been fully resolved. Our systems are now operating normally, and all inventory levels should be accurately reflected across sales channels.

Created
May 06 at 09:00am EDT

We are currently experiencing degraded performance with our Amazon Inventory Syncing services. Users may notice delays or inaccuracies in inventory levels being reflected across their sales channels. The issue has been identified, and our engineering team is actively working on implementing a fix.